Integration ALLER Updates in Windows 7

Tools, Installation, Optimierung, Problemlösung rund ums Thema Windows 7
Benutzeravatar
jpk
Member
Beiträge: 13
Registriert: Mo 16. Mär 2020, 17:43
    Linux Firefox
Hat sich bedankt: 5 Mal
Danksagung erhalten: 1 Mal
Status: Offline

Re: Integration ALLER Updates in Windows 7

#81

Beitrag von jpk » Di 31. Mär 2020, 18:41

Kleines Feedback: habe das neue ISO installiert (was auf meinem Board gar nicht so einfach war: bis ich die richtige Kombination aus BIOS-Modus, Partitionierungsstil, F6-Treibern usw. raus hatte), und alles lief letztlich reibungslos. Nur die Aktivierung ging nicht mit meinem offiziellen Key, der unten auf dem Laptop klebt, die Telefon-Aktivierung ging dann. Nun bekomme ich trotz der aktuellen Hosts-Datei und deaktiviertem WU diesen Screen immer wieder angezeigt:
screenshot.jpg
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

Benutzeravatar
g-force
Support
Beiträge: 335
Registriert: Mo 11. Jul 2016, 17:14
Wohnort: Schortens NDS
    Windows 10 Firefox
Hat sich bedankt: 125 Mal
Danksagung erhalten: 72 Mal
Kontaktdaten:
Status: Offline

Re: Integration ALLER Updates in Windows 7

#82

Beitrag von g-force » Di 31. Mär 2020, 21:57

Gib mir genaue Angaben über deine Hardware (Mainbord, Garafik, etc).
Desweiteren muß ich wissen, welche Win7-Edition Du installieren willst (Premium, Ultimate, etc).
Hast Du deinen Key bereits während der Installation eingegeben oder erst später?

Benutzeravatar
jpk
Member
Beiträge: 13
Registriert: Mo 16. Mär 2020, 17:43
    Linux Firefox
Hat sich bedankt: 5 Mal
Danksagung erhalten: 1 Mal
Status: Offline

Re: Integration ALLER Updates in Windows 7

#83

Beitrag von jpk » Do 2. Apr 2020, 00:55

MSI Z170A Krait, FirePro V4900, Samsung EVO 970 M2 SSD. Meinen Key wollte ich nach der Installation eingeben. Ausgewählt habe ich Windows 7 Professional.

Was auch nicht klappt ist side-by-side, ich habe versucht eine Anwendung mit einer .manifest-Datei zu starten: irgendwas mit den Redistributable-Paketen scheint nicht zu stimmen, aber das ist nur eine sehr vage Vermutung. Hier eine Anleitung dazu, mit der man normalerweise das Problem von nicht skalierenden Anwendungen lösen können sollte, auf meiner Installation klappt das aber leider nicht:

https://danantonielli.com/adobe-app-sca ... plays-fix/

[ gepostet mit Huawei P9 EVA-L09 ]
Zuletzt geändert von jpk am Do 2. Apr 2020, 15:40, insgesamt 1-mal geändert.

Benutzeravatar
g-force
Support
Beiträge: 335
Registriert: Mo 11. Jul 2016, 17:14
Wohnort: Schortens NDS
    Macintosh Firefox
Hat sich bedankt: 125 Mal
Danksagung erhalten: 72 Mal
Kontaktdaten:
Status: Offline

Re: Integration ALLER Updates in Windows 7

#84

Beitrag von g-force » Do 2. Apr 2020, 14:34

Was steht denn in "System"? Ist Windows aktiviert oder nicht?

Benutzeravatar
jpk
Member
Beiträge: 13
Registriert: Mo 16. Mär 2020, 17:43
    Linux Firefox
Hat sich bedankt: 5 Mal
Danksagung erhalten: 1 Mal
Status: Offline

Re: Integration ALLER Updates in Windows 7

#85

Beitrag von jpk » Do 2. Apr 2020, 15:39

Ja, ist aktiviert, ging wie beschrieben mit der telefonischen Aktivierung, aber nicht mit meinem Key.

Benutzeravatar
g-force
Support
Beiträge: 335
Registriert: Mo 11. Jul 2016, 17:14
Wohnort: Schortens NDS
    Macintosh Firefox
Hat sich bedankt: 125 Mal
Danksagung erhalten: 72 Mal
Kontaktdaten:
Status: Offline

Re: Integration ALLER Updates in Windows 7

#86

Beitrag von g-force » Fr 3. Apr 2020, 12:18

Dann verstehe ich nicht, warum Du weiterhin die Meldung angezeigt bekommst (Post 81, Screenshots).

Welche Probleme hattest Du denn bei der Installation? Wieso mußt Du F6 drücken, sowas gab es früher bei WinXP?
Im BIOS ist CSM erforderlich für Win7 - meinst Du das mit BIOS-Modus?

Benutzeravatar
jpk
Member
Beiträge: 13
Registriert: Mo 16. Mär 2020, 17:43
    Linux Chrome
Hat sich bedankt: 5 Mal
Danksagung erhalten: 1 Mal
Status: Offline

Re: Integration ALLER Updates in Windows 7

#87

Beitrag von jpk » Fr 3. Apr 2020, 13:01

Sorry für meine etwas missverständlichen Formulierungen. Ich versuche sie mal aufzuklären: viele BIOSse können wahlweise im UEFI Modus laufen: in den Einstellungen kann ich UEFI oder UEFI+legacy wählen. Ich musste auf nur-UEFI umstellen und dann von MBR auf GPT umpartitionieren, weil ich nur so von der NVME SSD booten konnte. Und F6 hab ich natürlich nicht gedrückt: F6-Treiber nennen manche Treiberversionen, die während der Installation eingebunden werden können.

https://praxistipps.chip.de/windows-7-a ... ppts_37326

Habe nun nach dieser Anleitung die Aktivierung deaktiviert: die hat sich aber von selbst repariert, obwohl ich keine Updates eingespielt habe. Dann habe ich sie nochmals deaktiviert und anschließend die 4 Dateien komplett gelöscht (von einem Linux live system aus: mehrere Kopien an verschiedenen Orten und deren .mui-Dateien), diesmal kamen sie nicht mehr zurück.

Die Meldung aus dem Screenshot von #81 kommt regelmäßig: vielleicht weil irgend eine Prüfung durch die hosts-Datei verhindert ist? Es scheint jedenfalls, dass sie nichts mit der Aktivierung zu tun hat. Und ich hatte ja die Aktivierung davor per Telefon erfolgreich durchgeführt. Würde es nicht reichen, das Programm, das diese Meldung verursacht, zu entfernen?

[ gepostet mit Huawei P9 EVA-L09 ]

Benutzeravatar
g-force
Support
Beiträge: 335
Registriert: Mo 11. Jul 2016, 17:14
Wohnort: Schortens NDS
    Macintosh Firefox
Hat sich bedankt: 125 Mal
Danksagung erhalten: 72 Mal
Kontaktdaten:
Status: Offline

Re: Integration ALLER Updates in Windows 7

#88

Beitrag von g-force » Fr 3. Apr 2020, 16:06

Deine Probleme mit der Aktivierung sind schon sehr merkwürdig, ich kann das hier auch nicht nachstellen oder replizieren.

Mußtest Du denn zusätzliche Treiber für die Installation einbinden? Eigentlich ist alles dabei (integriert).

Benutzeravatar
jpk
Member
Beiträge: 13
Registriert: Mo 16. Mär 2020, 17:43
    Linux Firefox
Hat sich bedankt: 5 Mal
Danksagung erhalten: 1 Mal
Status: Offline

Re: Integration ALLER Updates in Windows 7

#89

Beitrag von jpk » Sa 4. Apr 2020, 00:38

g-force hat geschrieben:
Fr 3. Apr 2020, 16:06
Mußtest Du denn zusätzliche Treiber für die Installation einbinden? Eigentlich ist alles dabei (integriert).
Letztlich bin ich bei der Installation mit den integrierten Treibern ausgekommmen, aber erst mit UEFI und GPT (ohne Reserve-MBR). Nach der Installation habe ich ein paar Treiber aktualisiert, u.a. einen Drucker, den mir WU vorgeschlagen hat. Ich habe aber nicht den Eindruck, dass meine Meldung mit Treibern zu tun hat...

Benutzeravatar
g-force
Support
Beiträge: 335
Registriert: Mo 11. Jul 2016, 17:14
Wohnort: Schortens NDS
    Macintosh Firefox
Hat sich bedankt: 125 Mal
Danksagung erhalten: 72 Mal
Kontaktdaten:
Status: Offline

Re: Integration ALLER Updates in Windows 7

#90

Beitrag von g-force » Sa 4. Apr 2020, 09:41

Daß ein Drucker-Treiber nachgeladen wird, ist völlig normal - die veralteten Druckertreiber habe ich alle entfernt.
Dein Aktivierungsproblem hat damit natürlich nichts zu tun.

Daß das OS im UEFI-Modus aufgesetzt werden sollte, muß ich in meiner Anleitung wohl nochmal verdeutlichen.
UEFI und 64bit ist heute sozusagen Standard, mit anderen Varianten beschäftige ich mich garnicht.

Benutzeravatar
jpk
Member
Beiträge: 13
Registriert: Mo 16. Mär 2020, 17:43
    Linux Firefox
Hat sich bedankt: 5 Mal
Danksagung erhalten: 1 Mal
Status: Offline

Re: Integration ALLER Updates in Windows 7

#91

Beitrag von jpk » Sa 4. Apr 2020, 14:06

g-force hat geschrieben:
Sa 4. Apr 2020, 09:41
Dein Aktivierungsproblem hat damit natürlich nichts zu tun.
Ist es überhaupt ein Aktivierungsproblem? Bevor ich die Aktivierung lahm gelegt habe, hatte ich sie ja per Telefon erfolgreich durchgeführt. Laut Google könnte der Fehlercode 0x8004fe22 darauf hinweisen, dass mein Key ein OEM-SLP statt ein OEM-COA Key ist (oder umgekehrt), aber mit dieser Info kann ich wenig anfangen: hast Du diesbezüglich Rat?

Benutzeravatar
g-force
Support
Beiträge: 335
Registriert: Mo 11. Jul 2016, 17:14
Wohnort: Schortens NDS
    Macintosh Firefox
Hat sich bedankt: 125 Mal
Danksagung erhalten: 72 Mal
Kontaktdaten:
Status: Offline

Re: Integration ALLER Updates in Windows 7

#92

Beitrag von g-force » Sa 4. Apr 2020, 22:39

Nein, ich habe diesbezüglich keinen Rat. Nach allen Berichten hier bist Du der Einzige mit diesem Problem, deswegen schließe ich einen Fehler in der ISO erstmal aus.

Benutzeravatar
Windown
Member
Beiträge: 11
Registriert: Di 10. Mär 2020, 09:21
    Windows 10 Firefox
Hat sich bedankt: 7 Mal
Danksagung erhalten: 3 Mal
Status: Offline

Re: Integration ALLER Updates in Windows 7

#93

Beitrag von Windown » Di 7. Apr 2020, 14:39

Bin leider jetzt erst zum Testen gekommen. Mal wieder Danke für deine Mühe.

Habe gerade die Win7 AIO x64 Final vom 20.3.2020 in ne VMWare Workstation 15 VM mit dem Preset für Win7 installiert.

Die Einstellung der VM hab ich folgendermaßen abgeändert:
- 16cores und 4GB Ram zur Verfügung gestellt
- Die NIC hab ich auf Disconnected at power on gesetzt, somit hat die Umgebung keinen Internetzugriff bis ich es aktiviere.

Die Installation von Win7 Enterprise (ich nutze ausschließlich Enterprise) ist in ca. 10-15 Minuten bis zum Desktop durch. Danach hab ich einfach noch die VMWare-Tools installiert. Es gibt im Betrieb bis jetzt folgende Problem:

- Vor Abschluss der VMWare-Tools-Installation bringt mit VMWareResolutionSet.exe folgende Fehlermeldung:
"Die Anweisung in 0x00000000 verweist auf Speicher 0x000000. Der Vorgang written konnte nicht im Speicher durchgeführt werden. Klicken Sie auf OK um das Programm zu beenden".
Wenn ich OK klicke, das Setup mittels Druck auf "Fertig" beende will die VM wegen der Treiberinstallationen neu starten.
Anmerkung dazu: Wahrscheinlich versucht das Programm vor dem Neustart schon die passende Auflösung zu setzen, aber aus irgend einem Grund scheint der Grafiktreiber noch nicht aktiv zu sein. Das ist mir bis jetzt noch nie passiert (auch bei der Ent-ISO vom 16.3. nicht). Nach dem Neustart hat das System aber automatisch die korrekte Auflösung eingestellt.
Scheint nicht weiter tragisch zu sein, ich schreibs nur der Vollständigkeit wegen.

- der IE funktioniert nicht / lässt sich nicht starten
-> wird leider benötigt um nen ordentlichen Browser nachladen zu können
-> Ich nutze Win7 unter anderem noch, um auf dämlich programmierte webinterfaces zu kommen (z.B. von Druckern), die ausschließlich mit IE richtig angezeigt werden bzw. die scripte ausschließlich mit IE laufen, daher würde ich mich über einen funktionierenden IE freuen

- Logischerweise erstmal auch keine Aktivierung von Windows möglich, da Aktivierungsserver nicht erreichbar. Dazu muss dann die hosts-Datei erstmal temporär verschoben werden.

Weitere Tests folgen noch.

Edit: Hab erst nach Erstellen von diesem Post die Mail von diesem Herrn gelesen. Da bleibt mir nur Kopfschütteln.

Benutzeravatar
g-force
Support
Beiträge: 335
Registriert: Mo 11. Jul 2016, 17:14
Wohnort: Schortens NDS
    Windows 10 Firefox
Hat sich bedankt: 125 Mal
Danksagung erhalten: 72 Mal
Kontaktdaten:
Status: Offline

Re: Integration ALLER Updates in Windows 7

#94

Beitrag von g-force » Di 7. Apr 2020, 14:46

Je mehr ich darüber nachdenke, umso so mehr ärgert es mich. Bevor ich mich allerdings auf diese abgrundtiefe Niveau herablasse, werde ich hier mal unerwartet reagieren.

Der Grund, warum ich die ISO derart stark bereinige und Komponenten entferne liegt einfach in der mönströsen Größe, die Win7 nach Installation aller Updates einnimmt.
Eine ISO von 8 GB (8.761.376.768 Byte) ist für den normalen User nicht akzeptabel. Zum Vergleich: Meine Final-ISO hat 3 GB (2.841.706.496 Byte)!
Ich habe also alle Möglichkeiten genutzt, die ISO auf ein vernüftiges Maß zu bringen - nicht nur strikte Bereinigung, sondern auch Entfernen unnützer Komponenten.
Der "Windows Defender" läßt sich unter Win7 nicht mehr aktualisieren und bremst das System unnötig aus - weg damit.
Die "Windows-Suche" verlangsamt das System beträchtlich, es gibt wesentlich bessere Alternativen (z.B. "Evereything") - also weg damit.
Das "Notepad" wurde nicht entfernt:
Win7-Windows-Notepad.PNG

Wer unbedingt die volle, komplette ISO braucht, kann sie von meinem GoogleDrive herunterladen: DOWNLOAD

Ich verwehre mich gegen solche Anschuldigungen und Beleidigungen. Ich mache das alles hier in meiner Freizeit und völlig freiwillig.
Ich bin nicht allwissend und ganz bestimmt nicht fehlerfrei, aber ich muß mich nicht als Dilletant beschimpfen lassen.
Immerhin kann ich ein altes Win7 auf moderner Hardware installieren - andere bekommen ein modernes Win8/10 nichtmal auf so einer simplen Möhre zum laufen.
Sich dann noch als heiliger Samariter aufzuspielen, der Mittellose mit einem Win7 (das ICH gemacht habe) beglücken will, ist schon dreist.

EDIT Mod TMC: Durchgestrichen durch Moderation. Kontext aufgrund Abtrennen des geistigen Ergusses eines Nutzers hier nicht mehr nachvollziehbar. Details siehe hier viewtopic.php?f=15&p=6109#p6109
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

Benutzeravatar
g-force
Support
Beiträge: 335
Registriert: Mo 11. Jul 2016, 17:14
Wohnort: Schortens NDS
    Windows 7 Firefox
Hat sich bedankt: 125 Mal
Danksagung erhalten: 72 Mal
Kontaktdaten:
Status: Offline

Re: Integration ALLER Updates in Windows 7

#95

Beitrag von g-force » Di 7. Apr 2020, 14:53

@Windown
Die HOSTS-Datei hat anscheinend doch einige Nachteile. Daß die Aktivierung blockiert wird, ist ein klarer Fehler (der mir in meiner VM nicht aufgefallen ist). Ich werde das überarbeiten.

Der IE machte bei mir keine Probleme, aber ich werde das überprüfen. Vielleicht sollte ich Firefox mit integrieren, den IE benutzt doch eh keiner.

Ich habe möglicherweise einen Treiber entfernt, der für VM-Ware nötig ist (ich teste in VirtualBox) - auch das werde ich überprüfen.

Danke für deinen Bericht und die konstruktive Kritik, nur so kann man ein solches Projekt perfektionieren! :friends:
Vielleicht können ein paar alte verbitterte PC-Techniker davon noch lernen... ;)

Benutzeravatar
Windown
Member
Beiträge: 11
Registriert: Di 10. Mär 2020, 09:21
    Windows 10 Firefox
Hat sich bedankt: 7 Mal
Danksagung erhalten: 3 Mal
Status: Offline

Re: Integration ALLER Updates in Windows 7

#96

Beitrag von Windown » Di 7. Apr 2020, 15:06

Zum IExplorer:

Das Verzeichnis C:\Program Files (x86)\Internet Explorer\ existiert zwar und es sind auch 21 Programmdateien darin, aber die iexplorer.exe fehlt. Ich hab die Exe mal mal aus einer anderen Win7-Maschine rübergezogen (War ein blankes Win7 Ent ohne SP1, was ich zum Vergleich bis zum letzten Update manuell hochgepatcht habe). Leider hat das keine Abhilfe gebracht.

Ich hab zwischenzeitlich auch die AIO vom 20.3. nochmal runtergeladen und damit nochmal ne frische VM aufgesetzt. Die Probleme waren identisch.

Benutzeravatar
Windown
Member
Beiträge: 11
Registriert: Di 10. Mär 2020, 09:21
    Windows 10 Firefox
Hat sich bedankt: 7 Mal
Danksagung erhalten: 3 Mal
Status: Offline

Re: Integration ALLER Updates in Windows 7

#97

Beitrag von Windown » Di 7. Apr 2020, 15:18

Und noch ne persönliche Anmerkung:

Ich finde es nicht schlimm, wenn die ISO an die 4,7GB hat. Selbst über 4,7GB fände ich nicht tragisch, denn entweder ich installiere auf physische Hosts mit USB-Stick, der dann idR 16GB oder größer ist, oder halt ne VM direkt von der ISO. Das einzige was ich sehe, warum man <=4,7GB bleiben sollte ist, weil nicht jeder Duallayer-Rohlinge hat bzw. brennen oder lesen kann und weil nicht jeder physische Host in der Lage ist, sauber von USB-Sticks installiert zu werden. Letzteres betrifft in der Regel irgendwelche komischen Notebooks oder billigheimerkomplett-PCs mit grottigem BIOS.

Wenn es also der Kompatibilität und auch der Funktionalität dienlich ist, habe ich nichts dagegen, wenn die ISO bis 4,7GB oder zur Not auch darüber hinaus wächst. Allein dass Win7 durch Updateinstallationen nicht mehr nachträglich größer wird, ist schon Gold wert. Da sind ein paar hundert MB oder ein paar GB beim installierten System für mein Empfinden nicht weiter tragisch. Mein frisch installiertes Win7 Ent. ohne SP1 war nach Installation und Datenträgerbereinigung mit Bordmitteln 32GB groß. Aktuell bist du bei etwa 7GB, das heißt da ist noch einiges an Luft nach oben. ;-)

Benutzeravatar
jpk
Member
Beiträge: 13
Registriert: Mo 16. Mär 2020, 17:43
    Linux Firefox
Hat sich bedankt: 5 Mal
Danksagung erhalten: 1 Mal
Status: Offline

Re: Integration ALLER Updates in Windows 7

#98

Beitrag von jpk » Di 7. Apr 2020, 18:09

g-force hat geschrieben:
Di 7. Apr 2020, 14:53
Die HOSTS-Datei hat anscheinend doch einige Nachteile.
Es würde mich sehr interessieren, ob die Hosts auch mit meinem Problem zu tun haben könnte...

Und bitte nicht ärgern über den Troll!!! Wie andere bereits schrieben: Deine Arbeit ist Gold wert, und es ist eine Frechheit was er schreibt. Als Rentner so unverschämtes und obendrein falsches Deutsch zu schreiben ist mehr als peinlich, damals hat man immerhin noch anständig Deutsch gelernt. Und von Computer-Technik hat er offenbar Null Ahnung, sonst hätte er niemals Stunden lang damit verbracht, sich über eine angeblich fehlende notepad.exe zu ärgern. Ich vermute, der Troll ist ein frustrierter Teenager, der keine gute Kinderstube hatte und herum lügt dass sich die Balken biegen. Allerdings sehr bedenklich finde ich, dass er auch noch tut, als ob er wohltätig sei. Wenn ihm nicht einmal auf fällt, dass er sich Wohltätigkeit auf die Fahnen schreiben und sich mit Deiner Arbeit schmücken wollte, dann weist das nur umso mehr darauf hin, dass auch seine Wohltätigkeit erfunden ist.

Benutzeravatar
-0070815-
Member
Beiträge: 20
Registriert: Mo 17. Okt 2016, 10:22
    Windows 7 Firefox
Danksagung erhalten: 7 Mal
Status: Offline

Re: Integration ALLER Updates in Windows 7

#99

Beitrag von -0070815- » Di 7. Apr 2020, 18:27

@Gunnar
Zuletzt habe ich deine Arbeit vom 08.02.2020 genutzt und, wie im #9 beschrieben, angepasst. Probleme habe ich da in 8 Wochen weder auf meinem PC (Core-I-6700) noch auf meinem Notebook (Core-i-42xxOU) feststellen können.
Ich werde deine letzt 8,2GB-Full-Driver-Version demnächst mal testen, wenn das Wetter schlechter wird; bisher bin ich ja mehr als zufrieden. Dafür vielen Dank.

Eigentlich sollte man bei diesem Wetter in den Zoo gehen, jedoch habe ich hier gerade gelesen, das die wohl im Home-Office sitzen.

Benutzeravatar
g-force
Support
Beiträge: 335
Registriert: Mo 11. Jul 2016, 17:14
Wohnort: Schortens NDS
    Macintosh Firefox
Hat sich bedankt: 125 Mal
Danksagung erhalten: 72 Mal
Kontaktdaten:
Status: Offline

Re: Integration ALLER Updates in Windows 7

#100

Beitrag von g-force » Di 7. Apr 2020, 18:33

jpk hat geschrieben:
Di 7. Apr 2020, 18:09
g-force hat geschrieben:
Di 7. Apr 2020, 14:53
Die HOSTS-Datei hat anscheinend doch einige Nachteile.
Es würde mich sehr interessieren, ob die Hosts auch mit meinem Problem zu tun haben könnte...
Ich denke, daß die Aktivierungs-Probleme mit der allzu strikten HOSTS zu tun haben.
Ich werde das in der kommenden Version berücksichtigen und die originale Hosts wieder einbauen. Unter "Programme (x86)/Toolbox" werden ich dann die Möglichkeit implementieren, eine angepasste HOSTS zu installieren.

Ich denke, daß die ISO tatsächlich etwas größer sein darf, ich werde etwas vorsichtiger sein bei der Entfernung von Komponenten. Es sind manchmal recht kleine Dinge, die große (nachteilige) Wirkung haben. Solange ich konstruktives Feedback bekomme, arbeite ich gerne weiter an dem Projekt.

Antworten

Social Media