Anmeldung mit MS-Konto nicht möglich nach Einrichtung mit answer file

Tools, Installation, Optimierung, Problemlösung rund ums Thema Windows 11
Antworten
Benutzeravatar
quest
Member
Beiträge: 5
Registriert: Fr 4. Mär 2022, 08:46
    Linux Chrome
Status: Offline

Anmeldung mit MS-Konto nicht möglich nach Einrichtung mit answer file

#1

Beitrag von quest » Fr 4. Mär 2022, 13:01

Hallo zusammen,

ich wollte mich ein wenig umsehen, wie ich beim einrichten vom Geräten Zeit sparen kann und habe mit den answer files von windowsafg.com eine angenehme Lösung gefunden. Nur auf ein Problem bin ich gestossen: Es ist scheinbar nicht möglich, nach der Einrichtung ein Microsoft-Konto hinzuzufügen. Beim verbinden eines Kontos mit dem lokalen Benutzer wird angezeigt das Passwort sei falsch, wenn ich ein neues Benutzerkonto anlege mit der Microsoft-Mail und mich damit anmelden möchte, kann ich auf "anmelden" klicken und es passiert nichts.

Weiss jemand woran das liegt? Habe ich eventuell eine falsche Einstellung gewählt?

Vielen Dank!

[ gepostet mit Android ]

Benutzeravatar
Thiersee
Support
Beiträge: 638
Registriert: Di 26. Jul 2016, 15:08
Wohnort: Tirol (Österreich)
    Windows 10 Firefox
Hat sich bedankt: 3 Mal
Danksagung erhalten: 52 Mal
Status: Offline

Re: Anmeldung mit MS-Konto nicht möglich nach Einrichtung mit answer file

#2

Beitrag von Thiersee » Sa 5. Mär 2022, 18:20

Vielleicht, weil der Autounattend.xml-Generator nicht W11-kompatibel ist und etwas mit hinein schreibt, das es verhindert?
Ich verwende seit jahren die autounattend.xml (selbst zusammengestrickt) und habe nie ein Problem mit dem MS-Konto gehabt.
MfG, Thiersee

Benutzeravatar
Bezelbube
Support
Beiträge: 42
Registriert: Sa 3. Sep 2016, 17:46
Wohnort: Daheim
    Windows 10 Firefox
Hat sich bedankt: 4 Mal
Danksagung erhalten: 37 Mal
Status: Offline

Re: Anmeldung mit MS-Konto nicht möglich nach Einrichtung mit answer file

#3

Beitrag von Bezelbube » Fr 18. Mär 2022, 03:14

@quest
Erstmal zum Verständnis, die autounattended.xml ist eine ANTWORTDATEI, welche in jeder Windowssetupphase eingelesen wird.
Im gegensatz dazu wird die setupcomplete.cmd oder firstlogon.cmd nur einmalig vom Setup eingelesen/ausgeführt.
Aufgrung deines Eingangspostes und der Formulierung darin, bin ich ein wenig verwirrt.
In der Antwortdatei kann man nur lokale Benutzer anlegen, welche am ende der oobe-setupphase angelegt werden.
Ein MS-Benutzerkonto benötigt eine Onlineverbindung, die aber erst nach dem laden des ersten Desktop´s verfügbar ist.
Bitte nicht irritieren lassen vom Windowssetup, welches in der oobe-setupphase nach Updates sucht,
es ist noch die Windowsinstallationsroutine die nach Updates sucht und kein gestartestes Windowsbetriebssystem.
Eine Offenbarung deiner Atwortdatei könnte Aufklärung geben.

Benutzeravatar
quest
Member
Beiträge: 5
Registriert: Fr 4. Mär 2022, 08:46
    Windows 10 Chrome
Status: Offline

Re: Anmeldung mit MS-Konto nicht möglich nach Einrichtung mit answer file

#4

Beitrag von quest » So 20. Mär 2022, 10:42

Hallo zusammen,

@Thiersee: laut Google hat sich praktisch nichts geändert hierzu, sollte (theoretisch) also alles gehen...
@Bezelbube: genau, die Antwortdatei richtet mir Windows ein bis ich auf dem Desktop bin, wenn dann eigentlich alles eingerichtet ist kann ich aber keinen Windows-Account hinzufügen. Ich gehe dazu in die Benutzerverwaltung und möchte dann einen weiteren Benutzer einrichten, werde dann nach dem MS-Konto gefragt (nur nach der E-Mail, kein Passwort) und muss mich dann abmelden, in Windows neu anmelden und dort die neue Mail anwählen. Wenn ich dort dann auf Anmelden klicke, passiert nichts. Auf einem klassisch eingerichteten System kommt dann das Microsoft-Login-Fenster.

Hier noch meine Antwortdatei:

Code: Alles auswählen

<!--*************************************************
Windows 10 Answer File Generator
Created using Windows AFG found at:
;http://www.windowsafg.com

Installation Notes
Location: 
Notes: Enter your comments here...
**************************************************-->

<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass="windowsPE">
<component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SetupUILanguage>
<UILanguage>de-DE</UILanguage>
</SetupUILanguage>
<InputLocale>0807:00000807</InputLocale>
<SystemLocale>de-DE</SystemLocale>
<UILanguage>de-DE</UILanguage>
<UILanguageFallback>de-DE</UILanguageFallback>
<UserLocale>de-CH</UserLocale>
</component>
<component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<DiskConfiguration>
<Disk wcm:action="add">
<DiskID>0</DiskID>
<WillWipeDisk>true</WillWipeDisk>
<CreatePartitions>
<!-- Windows RE Tools partition -->
<CreatePartition wcm:action="add">
<Order>1</Order>
<Type>Primary</Type>
<Size>300</Size>
</CreatePartition>
<!-- System partition (ESP) -->
<CreatePartition wcm:action="add">
<Order>2</Order>
<Type>EFI</Type>
<Size>100</Size>
</CreatePartition>
<!-- Microsoft reserved partition (MSR) -->
<CreatePartition wcm:action="add">
<Order>3</Order>
<Type>MSR</Type>
<Size>128</Size>
</CreatePartition>
<!-- Windows partition -->
<CreatePartition wcm:action="add">
<Order>4</Order>
<Type>Primary</Type>
<Extend>true</Extend>
</CreatePartition>
</CreatePartitions>
<ModifyPartitions>
<!-- Windows RE Tools partition -->
<ModifyPartition wcm:action="add">
<Order>1</Order>
<PartitionID>1</PartitionID>
<Label>WINRE</Label>
<Format>NTFS</Format>
<TypeID>DE94BBA4-06D1-4D40-A16A-BFD50179D6AC</TypeID>
</ModifyPartition>
<!-- System partition (ESP) -->
<ModifyPartition wcm:action="add">
<Order>2</Order>
<PartitionID>2</PartitionID>
<Label>System</Label>
<Format>FAT32</Format>
</ModifyPartition>
<!-- MSR partition does not need to be modified -->
<ModifyPartition wcm:action="add">
<Order>3</Order>
<PartitionID>3</PartitionID>
</ModifyPartition>
<!-- Windows partition -->
<ModifyPartition wcm:action="add">
<Order>4</Order>
<PartitionID>4</PartitionID>
<Label>OS</Label>
<Letter>C</Letter>
<Format>NTFS</Format>
</ModifyPartition>
</ModifyPartitions>
</Disk>
</DiskConfiguration>
<ImageInstall>
<OSImage>
<InstallTo>
<DiskID>0</DiskID>
<PartitionID>4</PartitionID>
</InstallTo>
<InstallToAvailablePartition>false</InstallToAvailablePartition>
</OSImage>
</ImageInstall>
<UserData>
<ProductKey>
<!-- Do not uncomment the Key element if you are using trial ISOs -->
<!-- You must uncomment the Key element (and optionally insert your own key) if you are using retail or volume license ISOs -->
<Key></Key>
<WillShowUI>Never</WillShowUI>
</ProductKey>
<AcceptEula>true</AcceptEula>
<FullName>w-lok</FullName>
<Organization>WAG</Organization>
</UserData>
</component>
</settings>
<settings pass="offlineServicing">
<component name="Microsoft-Windows-LUA-Settings" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<EnableLUA>false</EnableLUA>
</component>
</settings>
<settings pass="generalize">
<component name="Microsoft-Windows-Security-SPP" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SkipRearm>1</SkipRearm>
</component>
</settings>
<settings pass="specialize">
<component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<InputLocale>0807:00000807</InputLocale>
<SystemLocale>de-CH</SystemLocale>
<UILanguage>de-CH</UILanguage>
<UILanguageFallback>de-CH</UILanguageFallback>
<UserLocale>de-CH</UserLocale>
</component>
<component name="Microsoft-Windows-Security-SPP-UX" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SkipAutoActivation>true</SkipAutoActivation>
</component>
<component name="Microsoft-Windows-SQMApi" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<CEIPEnabled>0</CEIPEnabled>
</component>
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<ComputerName>w-lok-003</ComputerName>
<ProductKey>YTMG3-N6DKC-DKB77-7M9GH-8HVX7</ProductKey>
</component>
</settings>
<settings pass="oobeSystem">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<AutoLogon>
<Password>
<Value></Value>
<PlainText>true</PlainText>
</Password>
<Enabled>true</Enabled>
<Username>w-lok</Username>
</AutoLogon>
<OOBE>
<HideEULAPage>true</HideEULAPage>
<HideOEMRegistrationScreen>true</HideOEMRegistrationScreen>
<HideOnlineAccountScreens>true</HideOnlineAccountScreens>
<HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
<NetworkLocation>Home</NetworkLocation>
<SkipUserOOBE>true</SkipUserOOBE>
<SkipMachineOOBE>true</SkipMachineOOBE>
<ProtectYourPC>1</ProtectYourPC>
</OOBE>
<UserAccounts>
<LocalAccounts>
<LocalAccount wcm:action="add">
<Password>
<Value></Value>
<PlainText>true</PlainText>
</Password>
<Description>wag</Description>
<DisplayName>w-lok</DisplayName>
<Group>Administrators</Group>
<Name>wu-lok</Name>
</LocalAccount>
</LocalAccounts>
</UserAccounts>
<RegisteredOrganization>wag</RegisteredOrganization>
<RegisteredOwner>w-lok</RegisteredOwner>
<DisableAutoDaylightTimeSet>false</DisableAutoDaylightTimeSet>
<FirstLogonCommands>
<SynchronousCommand wcm:action="add">
<Description>Control Panel View</Description>
<Order>1</Order>
<CommandLine>reg add "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\ControlPanel" /v StartupPage /t REG_DWORD /d 1 /f</CommandLine>
<RequiresUserInput>true</RequiresUserInput>
</SynchronousCommand>
<SynchronousCommand wcm:action="add">
<Order>2</Order>
<Description>Control Panel Icon Size</Description>
<RequiresUserInput>false</RequiresUserInput>
<CommandLine>reg add "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\ControlPanel" /v AllItemsIconView /t REG_DWORD /d 0 /f</CommandLine>
</SynchronousCommand>
<SynchronousCommand wcm:action="add">
<Order>3</Order>
<RequiresUserInput>false</RequiresUserInput>
<CommandLine>cmd /C wmic useraccount where name="w-lok" set PasswordExpires=false</CommandLine>
<Description>Password Never Expires</Description>
</SynchronousCommand>
</FirstLogonCommands>
<TimeZone>W. Europe Standard Time</TimeZone>
</component>
</settings>
</unattend>
Einen schönen Sonntag wünsche ich euch.

Benutzeravatar
Thiersee
Support
Beiträge: 638
Registriert: Di 26. Jul 2016, 15:08
Wohnort: Tirol (Österreich)
    Windows 10 Firefox
Hat sich bedankt: 3 Mal
Danksagung erhalten: 52 Mal
Status: Offline

Re: Anmeldung mit MS-Konto nicht möglich nach Einrichtung mit answer file

#5

Beitrag von Thiersee » So 20. Mär 2022, 13:16

Ich habe gerade ein Test mit einer aus windowsafg.com generierten autounattend.xml gemacht:
es hat alles funktioniert, allerdings habe ich es al MBR in der VirtualBox gemacht.

Ich konnte neue Benutzer problemlos hinzufügen und mich damit anmelden; auch die Anmeldung mit meinem MS-Konto hat auch funktioniert: ich habe einen der angelegten Konten für die Anmeldun mit MS-Konto umgewandelt, problemlos!
und möchte dann einen weiteren Benutzer einrichten, werde dann nach dem MS-Konto gefragt (nur nach der E-Mail, kein Passwort
In der Maske, wo du dein email angeben solltest, mußt du auf "Ich habe die Informationen für diese Person nicht" und danach auf "Benutzer ohne Microsoft Konto hinzufügen" klicken, dann kannst du ein weiteres lokalen Konto anlegen.

Und einen (wichtigen):
die Wiederherstellungs-Partition wird mit der generierten Autounattend.xml mit einer Größe von 300 MB erzeugt und das ist oft zu wenig:
beim Upgraden auf neueren Versionen (z.B. 21H0---> 21H2) hat Windows die schlechte Angewonheit, einen Stück der C-Partition wegzuschnappen und eine neue Wiederherstellungs-Partition zu erzeugen, wenn die vorhandene ihm zu klein ist.
Mein Rat ist, in deiner Antwort-Datei den Wert von 300 auf mindestens 1000 zu ändern.

Wohl bemerkt: all das gilt für Windows 10; ob das Verhalten für Windows 11 gleich ist kann ich nicht sagen.
MfG, Thiersee

Benutzeravatar
quest
Member
Beiträge: 5
Registriert: Fr 4. Mär 2022, 08:46
    Linux Chrome
Status: Offline

Re: Anmeldung mit MS-Konto nicht möglich nach Einrichtung mit answer file

#6

Beitrag von quest » So 20. Mär 2022, 13:26

Hallo Thiersee,
ja, zusätzliche lokale Benutzerkonten gehen problemlos, Probleme machen nur Windows-Konti. Ich werde das mal mit einer Win10-iso ausprobieren mit dem selben Answer file.

Vielen Dank für den Tipp, dann mache ich die Wiederherstellungspartition grösser.

[ gepostet mit Android ]

Benutzeravatar
Thiersee
Support
Beiträge: 638
Registriert: Di 26. Jul 2016, 15:08
Wohnort: Tirol (Österreich)
    Windows 10 Firefox
Hat sich bedankt: 3 Mal
Danksagung erhalten: 52 Mal
Status: Offline

Re: Anmeldung mit MS-Konto nicht möglich nach Einrichtung mit answer file

#7

Beitrag von Thiersee » So 20. Mär 2022, 14:03

wenn dann eigentlich alles eingerichtet ist kann ich aber keinen Windows-Account hinzufügen
Hier hast du aber das Gegenteil geschrieben!

Ich habe es in meiner Antwort-Datei so eingerichtet:
a. 1 lokalen Benutzer OHNE Admin-Rechte
b. 1 lokalen Benutzer MIT Admin-Rechte
c. 1 zweiten lokalen Benutzer mit Admin-Rechte: bei diesem Benutzer gehe ich dann in der Kontenverwaltung und klicke "Stattdessen mit einem MS-Konto anmelden" und gebe meine Zugangsdaten ein (Benutzer/PW).
Da ich aber nicht dauernd mit dem MS-Konto angemeldet sein will, logge ich mich wieder aus und arbeite dann mit Konto a. oder b.
MfG, Thiersee

Benutzeravatar
quest
Member
Beiträge: 5
Registriert: Fr 4. Mär 2022, 08:46
    Windows 10 Chrome
Status: Offline

Re: Anmeldung mit MS-Konto nicht möglich nach Einrichtung mit answer file

#8

Beitrag von quest » So 20. Mär 2022, 15:20

Ah, jetzt sehe ich es, ich habe Windows und Microsoft hier durcheinander gebracht. Also zur Klarstellung:

- Win11 mit lokalem Benutzerkonto einrichten geht
- lokale Benutzerkonti erstellen geht
- lokales Benutzerkonto mit Microsoft-Konto verbinden geht nicht (Passwort sei falsch obwohl es gleichzeitig online eingegeben funktioniert)
- Microsoft-Konto hinzufügen geht nicht (Beim Klick auf "Anmelden" passiert nichts)

Eigentlich klappt alles so wie es soll ausser eben ein Microsoft-Konto hinzuzufügen/zu verknüpfen.

Benutzeravatar
Thiersee
Support
Beiträge: 638
Registriert: Di 26. Jul 2016, 15:08
Wohnort: Tirol (Österreich)
    Windows 10 Firefox
Hat sich bedankt: 3 Mal
Danksagung erhalten: 52 Mal
Status: Offline

Re: Anmeldung mit MS-Konto nicht möglich nach Einrichtung mit answer file

#9

Beitrag von Thiersee » So 20. Mär 2022, 15:43

quest hat geschrieben:
So 20. Mär 2022, 15:20
.....
- lokales Benutzerkonto mit Microsoft-Konto verbinden geht nicht (Passwort sei falsch obwohl es gleichzeitig online eingegeben funktioniert)
.....
Ob es mit Windows 11 zu tun hat, kann ich weder sagen noch testen, ich habe nämlich keinen Windows 11.

Wie verbindest du das lokale Benutzer- mit dem MS-Konto?
- Microsoft-Konto hinzufügen geht nicht (Beim Klick auf "Anmelden" passiert nichts)
...
Ein MS-Konto kann man seinem Windows NICHT hinzufügen!
Wie ich schon sagte, man kann ein lokales, schon existierendes Konto in einem MS-Konto "umwandeln" ("Stattdessen mit einem Microsoft Konto anmelden").
MfG, Thiersee

Benutzeravatar
quest
Member
Beiträge: 5
Registriert: Fr 4. Mär 2022, 08:46
    Windows 10 Chrome
Status: Offline

Re: Anmeldung mit MS-Konto nicht möglich nach Einrichtung mit answer file

#10

Beitrag von quest » So 20. Mär 2022, 16:13

lokales Konto in MS-Konto umwandeln versuche ich über "Stattdessen mit einem Microsoft Konto anmelden" in der Benutzerverwaltung, wie du es gesagt hast.
Das was ich als MS-Konto hinzufügen bezeichnet habe, findet sich ebenfalls in der Benutzerverwaltung. Wenn ich einen Benutzer erstellen möchte, werde ich, wie auf dem Bild ersichtlich, als erstes nach einem MS-Konto gefragt. Füge ich dort die Adresse meines MS-Konto ein, wird es angenommen und angezeigt, dass beim erstmaligen Anmelden eine Internetverbindung notwendig ist. Also melde ich mich ab, suche unten links dann die E-Mail Adresse aus die ich gerade hinzugefügt habe, möchte dann auf "Anmelden" klicken und es passiert - nichts.

Dass ich hier auch ein lokales Konto erstellen kann ist mir bewusst, bringt mir aber nichts, da eben auch das spätere umwandeln dessen nicht klappt.

Vielen Dank und einen schönen Sonntag wünsche ich.
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

Antworten